Start a new topic

RED-LED on 3-space wireless 1.0

Hello everyone!

I am having the following problem: I was using the 3-space wireless sensor for about 2 years in an head tracking application and it worked like a charm. three weeks ago one of the devices im using stopped working. Always wenn i connect it to power the status led goes blue for about a second after that it goes red and stays like this.
Soon after (about one week later) the second device i was using also started to have the same problem. 

I tried then to check if the sensor would work with the sensor suite, but it was unable to connect to my sensor devices. I plugged the sensor into my usb port (once on win7 and once on win10) the sensor got reccognized and the driver was installed without problems. When i open the suite it displays my wireless sensor on the correct com port. But when i try to connect to the sensor it always says "connecting" and stays like that. I have this behavior on both my pcs...

Any suggestions on that problem?
Best regards,

1 person has this question
1 Comment


1. First, make sure you have downloaded the latest firmware version available on our website.

2. Run the 3-Space Sensor Suite in debug mode by opening a command window in the Suite directory, and running the executable with -d at the end ("3SpaceSuite.exe -d").

3. Try to connect to the sensor in the 3-Space Sensor Suite GUI mode (the default mode). If the Connection Status reads Bootloader Connected, attempt to update the firmware by selecting Update Firmware from the Bootloader menu and selecting the downloaded firmware file.

4. If you are unable to connect to the sensor in GUI mode, try connecting in Terminal mode (you can switch between modes under the File menu). If the Connection Status reads "Opened", try to update the firmware by selecting Update Firmware from the Sensor menu.

5. If the sensor LED does not return to blue after the update, try updating the firmware one more time.

6. If the LED is still red, try to send command :229 in the Terminal window. Then disconnect and reconnect to the sensor, and send a "?" (without quotes). If the sensor returns "OK", the sensor is now in Bootloader mode and you can switch back to GUI mode and try step 3 again.

7. If this still doesn't work, then try the failsafe: Short the top 2 pins on the sensor board as you are powering it on. This should put the sensor into Bootloader mode, and from there you should be able to try step 3 again.

Login or Signup to post a comment